Categories
notas código

The package needs to be reinstalled

Outro dia o apt-get falhou na hora de atualizar um pacote vindo de um ppa (gwibber-daily, no caso).

The package needs to be reinstalled, but I can’t find an archive for it.

Resultado: não conseguia reinstalar o pacote nem removê-lo. Hoje encontrei a solução:

$ sudo rm /var/lib/dpkg/info/pacote.prerm #Deleta arquivo problemático
$ sudo dpkg-reconfigure pacote --force #Força a reconfiguração do pacote
$ sudo dpkg --purge --force-all pacote #Força a remoção do pacote
$ sudo apt-get install pacote #Instala de novo, se quiser...

via superuser

Só pra compartilhar e achar fácil quando acontecer de novo…

Reply by Email

or

Leave a Comment

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *